Pages: 12345 »
Posted on 09-25-16, 04:03 am
Normal user
Posts: 1/14
Since: 07-12-16

Last post: 15 days
Last view: 3 hours

Quick-E-Links:
Sorry to post something unrelated to NSMBU or Wii U hacking, but I have a few questions related to New/Newer SMBW. Not sure when/if Rvlution will return, and I know there are a good amount of users from it here.

1. So Reggie Next has this problem where it won't save a level if it has more than one path in it, which I'm pretty sure was already known. It will save, however, when using the older Reggie. This is fine, but it gives me a problem when using more than one connected pipe. Whenever I set the direction for the connected pipe to exit out of, then save the paths in older Reggie, it changes all the exits to all the pipes to "up." This means that I can only make connected pipes that are exiting up, unless there is only one in the level. Is there a way to solve this issue? Sorry for the long description but I wanted to be as thorough as possible.

2. So I get magic platforms, but I have an issue. I wanted to get a pipe from a tileset to move left, which I set with a location and magic platform moving 2 blocks left. Now it does move correctly, but it leaves the original pipe behind, so it basically makes two pipes. Does anyone know why?

3. I've noticed that there are some tilesets in Newer that do not work on Layer 0. Whenever I put Layer 0 down, it flickers and you can see through it. It does in fact work as layer 0, but the flickering ruins the secret effect. Does anyone know how to fix this?

Thanks if you bothered to read this, and I'd appreciate any answers, or if there is a better place to ask these type of questions.
Posted on 09-25-16, 06:59 am

Shyguy
Normal user
Posts: 65/90
Since: 08-23-15

Last post: 57 days
Last view: 11 days

Quick-E-Links:
Question 2: You should place the tiles with a location around them somewhere under the zone border or somewhere else where they're not visible. The magic platform doesn't move tiles, it draws a moving copy of them with solid collisions.
_________________________
My YouTube channel (mostly featuring assembly hacks): Click here
Posted on 09-25-16, 09:10 am
Administrator
Posts: 127/171
Since: 08-11-15

Last post: 5 days
Last view: 3 days

Quick-E-Links:
3: That may be because of animations, in which case you can't solve it.

Fixing 1 means someone has to look into the saving bug in Reggie Next, and I think/know that its original coders are busy with NewerU.
Posted on 09-25-16, 06:15 pm

Red Paratroopa
Normal user

Posts: 9/174
Since: 03-16-16

Last post: 20 hours
Last view: 12 hours

Quick-E-Links:
I was wondering why I had problems saving a particular level.
_________________________
| Project ???
Posted on 09-25-16, 08:19 pm

Bullet Bill
Normal user

Posts: 201/523
Since: 03-06-16

Last post: 27 min.
Last view: 9 min.

Quick-E-Links:
An easy fix around it is to use Newer Reggie! which I'm pretty sure is on Zementblock's Google drive
Posted on 09-25-16, 09:43 pm

Red Paratroopa
I left for a real long break of two weeks

Posts: 57/165
Since: 06-06-16

Last post: 20 days
Last view: 4 days

Quick-E-Links:
Well, question 3 solves why the animated Newer lava always appeared on layer 2.
_________________________
I guess I'm not leaving the site then. I seem to be back, but you never know.
Posted on 09-26-16, 12:25 am
Owner
Posts: 191/244
Since: 08-11-15

Last post: 5 days
Last view: 1 day

Quick-E-Links:
Fixing 1 means someone has to look into the saving bug in Reggie Next, and I think/know that its original coders are busy with NewerU.

I actually fixed this a while ago and gave it to someone (Meorge?). He probably still has it.
_________________________
The Red Hat Café Welcome!
Posted on 09-26-16, 12:43 am
Normal user
Posts: 22/64
Since: 08-19-15

Last post: 65 days
Last view: 1 day

Quick-E-Links:
I don't remember getting a copy of Reggie Next with any fixes like that, unfortunately.
If I did, it's probably a part of https://github.com/Meorge/Reggie-Next-Collab
Posted on 09-26-16, 06:51 pm
Owner
Posts: 193/244
Since: 08-11-15

Last post: 5 days
Last view: 1 day

Quick-E-Links:
It might have been Zementblock, then. At any rate, it's a one-line fix and I remember what it is, so I can fix it in any bugged copy.
_________________________
The Red Hat Café Welcome!
Posted on 09-26-16, 06:53 pm

Bullet Bill
Normal user

Posts: 210/523
Since: 03-06-16

Last post: 27 min.
Last view: 9 min.

Quick-E-Links:
Would I need to have an un-compiled version, or can you fix it with a compiled version?
Posted on 09-29-16, 02:58 pm

Bullet Bill
Normal user

Posts: 222/523
Since: 03-06-16

Last post: 27 min.
Last view: 9 min.

Quick-E-Links:
Could someone share the link to the ofcial installer for Reggie! Next?

W10 reset my computer and browsing RVLution for it through the web archives isn't happening
Posted on 09-29-16, 03:39 pm
Administrator
Posts: 130/171
Since: 08-11-15

Last post: 5 days
Last view: 3 days

Quick-E-Links:
1. So Reggie Next has this problem where it won't save a level if it has more than one path in it, which I'm pretty sure was already known. It will save, however, when using the older Reggie. This is fine, but it gives me a problem when using more than one connected pipe. Whenever I set the direction for the connected pipe to exit out of, then save the paths in older Reggie, it changes all the exits to all the pipes to "up." This means that I can only make connected pipes that are exiting up, unless there is only one in the level. Is there a way to solve this issue? Sorry for the long description but I wanted to be as thorough as possible.
Since the fix seemed to have disappeared, I decided to look into it. The bug was quite easy to fix, actually. Open reggie.py (in a text editor or IDLE) and seach for "def SavePathNodes(self, buffer, offst, nodes):". Right after this, add the following line (on a new line, making sure it's on the same indentation level as the code following it).
buffer = bytearray(buffer)
Posted on 09-29-16, 04:21 pm (rev. 2 by customlevelfan78 on 09-29-16, 04:21 pm)

Rex
I don't really have faith in humanity.
Posts: 252/528
Since: 08-24-15

Last post: 5 hours
Last view: 5 hours

Quick-E-Links:
There's the public beta 1 in ZementBlock's Google Drive folder along with updated spritedata and spritecategories.

Can't you see W10 sucks ?
Posted on 10-03-16, 02:54 am
Normal user
Posts: 2/14
Since: 07-12-16

Last post: 15 days
Last view: 3 hours

Quick-E-Links:
Okay, thanks to everyone who answered the previous questions. Now I have another. I'm making a level based on the pyramid castle from Newer 2-castle, with statues becoming sprites after hitting a switch. I've gotten it to work, but the actor spawner states that if Mario goes off screen then re enters, the sprite won't be there. It says I can fix this with locations and events, but could someone explain how I could do this?
Posted on 10-03-16, 07:25 am

Rex
I don't really have faith in humanity.
Posts: 256/528
Since: 08-24-15

Last post: 5 hours
Last view: 5 hours

Quick-E-Links:
Is that even right ? I think it works even offscreen. Anyway, use sprite 38 with a location to spawn the sprite near Mario.
Posted on 10-04-16, 03:21 am
Normal user
Posts: 3/14
Since: 07-12-16

Last post: 15 days
Last view: 3 hours

Quick-E-Links:
Yes, the actor spawner will disappear after being offscreen for a certain amount of time. Or at least that's what is happening for me. So I know that sprite 38 is what I should use, but is there a way to have it be event activated? I want to hit a switch to trigger sprite 38, so anything in the location doesn't get affected until the switch has been hit.
Posted on 10-04-16, 05:37 am

Rex
I don't really have faith in humanity.
Posts: 263/528
Since: 08-24-15

Last post: 5 hours
Last view: 5 hours

Quick-E-Links:
Oh. In sprite 38 you can set a Triggering Event ID i believe. If you cannot, the workaround is simple.
Posted on 10-05-16, 02:33 pm

Bullet Bill
Normal user

Posts: 243/523
Since: 03-06-16

Last post: 27 min.
Last view: 9 min.

Quick-E-Links:
Can anyone give me specific on how I can spawn in any tile using the tile god event?

I'm trying to make different types of ground spawn in, but I have no clue how to get the tileset row and and column :/
Posted on 10-05-16, 03:23 pm

Rex
I don't really have faith in humanity.
Posts: 268/528
Since: 08-24-15

Last post: 5 hours
Last view: 5 hours

Quick-E-Links:
Quite simple. Open the required tileset with Puzzle and count from the top left how many squares are neeeded. Keep in mind that the first tile has a value of 0, since the 16th tile has a value of 15.
Posted on 10-05-16, 05:51 pm

Bullet Bill
Normal user

Posts: 244/523
Since: 03-06-16

Last post: 27 min.
Last view: 9 min.

Quick-E-Links:
Hmmm, I guess that makes sense

but then how is the coin 1,14? That is NOT where the coin is in puzzle
Pages: 12345 »